Joomla 4.0.x < 4.2.4 Multiple Vulnerabilities (5870-joomla-4-2-4-security-release)

medium Nessus Plugin ID 166467


A PHP application running on the remote web server is affected by multiple vulnerabilities.


According to its self-reported version, the instance of Joomla! running on the remote web server is 4.0.x prior to 4.2.4. It is, therefore, affected by multiple vulnerabilities.

- Joomla 4 sites with publicly enabled debug mode exposed data of previous requests. (CVE-2022-27912)

- Inadequate filtering of potentially malicious user input leads to reflected XSS vulnerabilities in various components. (CVE-2022-27913)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Joomla! version 4.2.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 166467

File Name: joomla_424.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 10/25/2022

Updated: 6/5/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 3.0


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2022-27913


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:joomla:joomla%5c%21

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/Joomla!

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No known exploits are available

Patch Publication Date: 10/25/2022

Vulnerability Publication Date: 10/25/2022

Reference Information

CVE: CVE-2022-27912, CVE-2022-27913

IAVA: 2022-A-0450-S, 2022-A-0490-S