Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS : LibreOffice vulnerabilities (USN-5694-1)

high Nessus Plugin ID 166339

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5694-1 advisory.

- If LibreOffice has an encrypted document open and crashes, that document is auto-saved encrypted. On restart, LibreOffice offers to restore the document and prompts for the password to decrypt it. If the recovery is successful, and if the file format of the recovered document was not LibreOffice's default ODF file format, then affected versions of LibreOffice default that subsequent saves of the document are unencrypted. This may lead to a user accidentally saving a MSOffice file format document unencrypted while believing it to be encrypted. This issue affects: LibreOffice 6-3 series versions prior to 6.3.6; 6-4 series versions prior to 6.4.3. (CVE-2020-12801)

- ODF documents can contain forms to be filled out by the user. Similar to HTML forms, the contained form data can be submitted to a URI, for example, to an external web server. To create submittable forms, ODF implements the XForms W3C standard, which allows data to be submitted without the need for macros or other active scripting Prior to version 6.4.4 LibreOffice allowed forms to be submitted to any URI, including file: URIs, enabling form submissions to overwrite local files. User-interaction is required to submit the form, but to avoid the possibility of malicious documents engineered to maximize the possibility of inadvertent user submission this feature has now been limited to http[s] URIs, removing the possibility to overwrite local files. This issue affects: The Document Foundation LibreOffice versions prior to 6.4.4.
(CVE-2020-12803)

- LibreOffice supports Office URI Schemes to enable browser integration of LibreOffice with MS SharePoint server. An additional scheme 'vnd.libreoffice.command' specific to LibreOffice was added. In the affected versions of LibreOffice links using that scheme could be constructed to call internal macros with arbitrary arguments. Which when clicked on, or activated by document events, could result in arbitrary script execution without warning. This issue affects: The Document Foundation LibreOffice 7.4 versions prior to 7.4.1; 7.3 versions prior to 7.3.6. (CVE-2022-3140)

- An Improper Certificate Validation vulnerability in LibreOffice existed where determining if a macro was signed by a trusted author was done by only matching the serial number and issuer string of the used certificate with that of a trusted certificate. This is not sufficient to verify that the macro was actually signed with the certificate. An adversary could therefore create an arbitrary certificate with a serial number and an issuer string identical to a trusted certificate which LibreOffice would present as belonging to the trusted author, potentially leading to the user to execute arbitrary code contained in macros improperly trusted. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1. (CVE-2022-26305)

- LibreOffice supports the storage of passwords for web connections in the user's configuration database.
The stored passwords are encrypted with a single master key provided by the user. A flaw in LibreOffice existed where the required initialization vector for encryption was always the same which weakens the security of the encryption making them vulnerable if an attacker has access to the user's configuration data. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1. (CVE-2022-26306)

- LibreOffice supports the storage of passwords for web connections in the user's configuration database.
The stored passwords are encrypted with a single master key provided by the user. A flaw in LibreOffice existed where master key was poorly encoded resulting in weakening its entropy from 128 to 43 bits making the stored passwords vulerable to a brute force attack if an attacker has access to the users stored config. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.3. (CVE-2022-26307)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5694-1

Plugin Details

Severity: High

ID: 166339

File Name: ubuntu_USN-5694-1.nasl

Version: 1.6

Type: local

Agent: unix

Published: 10/20/2022

Updated: 7/10/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2020-12801

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-26307

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-vi, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-pa-in, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-si, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-za, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-nn, p-cpe:/a:canonical:ubuntu_linux:libreoffice-smoketest-data, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-mn, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ts, p-cpe:/a:canonical:ubuntu_linux:libreoffice-wiki-publisher, p-cpe:/a:canonical:ubuntu_linux:libreoffice-gtk2, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-hi, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ml, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-fi, p-cpe:/a:canonical:ubuntu_linux:libreoffice-script-provider-bsh, p-cpe:/a:canonical:ubuntu_linux:python3-access2base, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-hr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-dev-gui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-sv, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-xh, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-galaxy, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-om, p-cpe:/a:canonical:ubuntu_linux:libreoffice-kde5, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-dz, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-hu, p-cpe:/a:canonical:ubuntu_linux:libreoffice-java-common, p-cpe:/a:canonical:ubuntu_linux:libreoffice-gnome, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-fr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-vi, p-cpe:/a:canonical:ubuntu_linux:libreoffice-writer, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ve, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-yaru, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-sl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-calc, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-kk, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-pt, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-pt-br, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-id, p-cpe:/a:canonical:ubuntu_linux:libunoloader-java, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-eu, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-el, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-it, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ru, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ast, p-cpe:/a:canonical:ubuntu_linux:libreoffice-common, p-cpe:/a:canonical:ubuntu_linux:uno-libs-private, p-cpe:/a:canonical:ubuntu_linux:libreoffice-core, p-cpe:/a:canonical:ubuntu_linux:libreoffice-math, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-zh-tw, p-cpe:/a:canonical:ubuntu_linux:libreoffice-report-builder-bin, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-am, p-cpe:/a:canonical:ubuntu_linux:libreoffice-ogltrans, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-in, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-szl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-sdbc-postgresql, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-nso, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-lv, p-cpe:/a:canonical:ubuntu_linux:libreoffice-mysql-connector, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-cs, p-cpe:/a:canonical:ubuntu_linux:ure, p-cpe:/a:canonical:ubuntu_linux:libreoffice-librelogo, p-cpe:/a:canonical:ubuntu_linux:fonts-opensymbol, p-cpe:/a:canonical:ubuntu_linux:libreoffice-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-zh-cn, p-cpe:/a:canonical:ubuntu_linux:libreoffice-kf5, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-nr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-en-gb, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-fr, p-cpe:/a:canonical:ubuntu_linux:libuno-sal3, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-tg, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-pl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-draw-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-calc-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-core-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-mk, p-cpe:/a:canonical:ubuntu_linux:libreoffice-report-builder, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-pt-br, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-zh-cn, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-hicontrast, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-is, p-cpe:/a:canonical:ubuntu_linux:libreofficekit-dev, p-cpe:/a:canonical:ubuntu_linux:libreoffice-script-provider-js, p-cpe:/a:canonical:ubuntu_linux:libreoffice-subsequentcheckbase, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-sk, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-or, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-pl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-dz, p-cpe:/a:canonical:ubuntu_linux:libjurt-java, p-cpe:/a:canonical:ubuntu_linux:libjuh-java, p-cpe:/a:canonical:ubuntu_linux:libreoffice-kde4, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-bn, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-om, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-sk, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-be, p-cpe:/a:canonical:ubuntu_linux:libreoffice-sdbc-firebird, p-cpe:/a:canonical:ubuntu_linux:libreoffice-math-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-en-gb, p-cpe:/a:canonical:ubuntu_linux:liblibreoffice-java, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-de, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ar, p-cpe:/a:canonical:ubuntu_linux:libreoffice-gtk3, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-sl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ro, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-uz, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-breeze, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-gl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-oxygen, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-mr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ss, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ja, p-cpe:/a:canonical:ubuntu_linux:uno-libs3, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-sr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-it, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-gl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-he, p-cpe:/a:canonical:ubuntu_linux:libreoffice-evolution, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-da, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-sifr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-elementary, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-te, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-eu, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-oc, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-pt, p-cpe:/a:canonical:ubuntu_linux:libreoffice-gtk, p-cpe:/a:canonical:ubuntu_linux:libreoffice-pdfimport, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-hi, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libreoffice-draw, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ta, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-zh-tw, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-ca, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-rw, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-human, p-cpe:/a:canonical:ubuntu_linux:libreoffice-base-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-de, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-karasa-jaga, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-es, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-br, p-cpe:/a:canonical:ubuntu_linux:libuno-cppu3, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-bs, p-cpe:/a:canonical:ubuntu_linux:libreoffice, p-cpe:/a:canonical:ubuntu_linux:libreoffice-sdbc-mysql, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-st, p-cpe:/a:canonical:ubuntu_linux:liblibreofficekitgtk, p-cpe:/a:canonical:ubuntu_linux:libreoffice-dev-common, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-lt, p-cpe:/a:canonical:ubuntu_linux:libreoffice-systray, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-ru, p-cpe:/a:canonical:ubuntu_linux:libreoffice-base, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-km, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-ko, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-en-us, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-kmr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-fi, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-da, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-es, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-cy, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-colibre, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ka, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-tr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-el, p-cpe:/a:canonical:ubuntu_linux:libreoffice-writer-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-eo, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-kn, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ug, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ga, p-cpe:/a:canonical:ubuntu_linux:libreoffice-impress-nogui, p-cpe:/a:canonical:ubuntu_linux:libreoffice-base-drivers, p-cpe:/a:canonical:ubuntu_linux:libuno-cppuhelpergcc3-3, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-km, p-cpe:/a:canonical:ubuntu_linux:libreoffice-sdbc-hsqldb, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-nl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-cs, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-bg, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-uk, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-th, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-as, p-cpe:/a:canonical:ubuntu_linux:libunoil-java, p-cpe:/a:canonical:ubuntu_linux:libreoffice-report-builder-bin-nogui, p-cpe:/a:canonical:ubuntu_linux:libuno-purpenvhelpergcc3-3, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-tango, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-nb, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-id, p-cpe:/a:canonical:ubuntu_linux:libreoffice-impress, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-gd, p-cpe:/a:canonical:ubuntu_linux:python3-uno, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-gug, p-cpe:/a:canonical:ubuntu_linux:libreoffice-script-provider-python, p-cpe:/a:canonical:ubuntu_linux:libuno-salhelpergcc3-3, p-cpe:/a:canonical:ubuntu_linux:libreoffice-qt5, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-sv, p-cpe:/a:canonical:ubuntu_linux:libreoffice-base-core, p-cpe:/a:canonical:ubuntu_linux:libreoffice-nlpsolver, p-cpe:/a:canonical:ubuntu_linux:libreoffice-style-sukapura, p-cpe:/a:canonical:ubuntu_linux:libreofficekit-data, p-cpe:/a:canonical:ubuntu_linux:ure-java, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-et, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-tr, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-tn, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ne, p-cpe:/a:canonical:ubuntu_linux:libreoffice-avmedia-backend-gstreamer, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-zu, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ko, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-af, p-cpe:/a:canonical:ubuntu_linux:libreoffice-dev, p-cpe:/a:canonical:ubuntu_linux:libreoffice-kde, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-nl, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-fa, p-cpe:/a:canonical:ubuntu_linux:libreoffice-plasma, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-en-za, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-gu, p-cpe:/a:canonical:ubuntu_linux:libridl-java, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-common, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-et, p-cpe:/a:canonical:ubuntu_linux:gir1.2-lokdocview-0.1, p-cpe:/a:canonical:ubuntu_linux:libreoffice-help-ja, p-cpe:/a:canonical:ubuntu_linux:libofficebean-java, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-ca, p-cpe:/a:canonical:ubuntu_linux:libreoffice-officebean, p-cpe:/a:canonical:ubuntu_linux:libreoffice-l10n-hu

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 10/20/2022

Vulnerability Publication Date: 5/18/2020

Reference Information

CVE: CVE-2020-12801, CVE-2020-12803, CVE-2022-26305, CVE-2022-26306, CVE-2022-26307, CVE-2022-3140

IAVB: 2022-B-0024-S, 2022-B-0040-S

USN: 5694-1