VMware vCenter Server 6.5 < 6.5 U3u RCE (VMSA-2022-0025)

critical Nessus Plugin ID 166101


A virtualization management application installed on the remote host is affected by a remote code execution vulnerability.


The version of VMware vCenter Server installed on the remote host is 6.5 prior to 6.5 U3u. It is, therefore, affected by a remote code execution vulnerability due to unsafe deserialization. A remote attacker with admin privileges on the affected server can exploit this vulnerability to execute arbitrary code on the underlying operation system that hosts the vCenter Server.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number. Nessus has also not tested for the presence of a workaround.


Upgrade to VMware vCenter Server 6.5 U3u or later.

See Also


Plugin Details

Severity: Critical

ID: 166101

File Name: vmware_vcenter_vmsa-2022-0025.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 10/13/2022

Updated: 10/9/2023

Supported Sensors: Nessus

Risk Information


Risk Factor: High

Score: 7.3


Risk Factor: High

Base Score: 8.3

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:M/C:C/I:C/A:C

CVSS Score Source: CVE-2022-31680


Risk Factor: Critical

Base Score: 9.1

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/6/2022

Vulnerability Publication Date: 10/6/2022

Reference Information

CVE: CVE-2022-31680

IAVA: 2022-A-0402-S