Debian DLA-3138-1 : bind9 - LTS security update

high Nessus Plugin ID 165715

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-3138 advisory.

- By flooding the target resolver with queries exploiting this flaw an attacker can significantly impair the resolver's performance, effectively denying legitimate clients access to the DNS resolution service.
(CVE-2022-2795)

- By spoofing the target resolver with responses that have a malformed ECDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources. (CVE-2022-38177)

- By spoofing the target resolver with responses that have a malformed EdDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources. (CVE-2022-38178)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the bind9 packages.

For Debian 10 buster, these problems have been fixed in version 1

See Also

https://security-tracker.debian.org/tracker/CVE-2022-38178

https://packages.debian.org/source/buster/bind9

https://security-tracker.debian.org/tracker/source-package/bind9

https://www.debian.org/lts/security/2022/dla-3138

https://security-tracker.debian.org/tracker/CVE-2022-2795

https://security-tracker.debian.org/tracker/CVE-2022-38177

Plugin Details

Severity: High

ID: 165715

File Name: debian_DLA-3138.nasl

Version: 1.4

Type: local

Agent: unix

Published: 10/5/2022

Updated: 1/26/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2022-38178

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:bind9, p-cpe:/a:debian:debian_linux:bind9-doc, p-cpe:/a:debian:debian_linux:bind9-host, p-cpe:/a:debian:debian_linux:bind9utils, p-cpe:/a:debian:debian_linux:dnsutils, p-cpe:/a:debian:debian_linux:libbind-dev, p-cpe:/a:debian:debian_linux:libbind-export-dev, p-cpe:/a:debian:debian_linux:libbind9-161, p-cpe:/a:debian:debian_linux:libdns-export1104, p-cpe:/a:debian:debian_linux:libdns1104, p-cpe:/a:debian:debian_linux:libirs-export161, p-cpe:/a:debian:debian_linux:libirs161, p-cpe:/a:debian:debian_linux:libisc-export1100, p-cpe:/a:debian:debian_linux:libisc1100, p-cpe:/a:debian:debian_linux:libisccc-export161, p-cpe:/a:debian:debian_linux:libisccc161, p-cpe:/a:debian:debian_linux:libisccfg-export163, p-cpe:/a:debian:debian_linux:libisccfg163, p-cpe:/a:debian:debian_linux:liblwres161, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/5/2022

Vulnerability Publication Date: 9/21/2022

Reference Information

CVE: CVE-2022-2795, CVE-2022-38177, CVE-2022-38178

IAVA: 2022-A-0387-S