PHP 8.0.x < 8.0.24 Multiple Vulnerabilities

medium Nessus Plugin ID 165622

Synopsis

The version PHP running on the remote web server is affected by multiple vulnerabilities.

Description

The version of PHP installed on the remote host is prior to 8.0.24. It is, therefore, affected by multiple vulnerabilities as referenced in the Version 8.0.24 advisory.

- In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the phar uncompressor code would recursively uncompress quines gzip files, resulting in an infinite loop. (CVE-2022-31628)

- In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications. (CVE-2022-31629)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 8.0.24 or later.

See Also

http://bugs.php.net/81726

http://bugs.php.net/81727

http://php.net/ChangeLog-8.php#8.0.24

Plugin Details

Severity: Medium

ID: 165622

File Name: php_8_0_24.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 10/2/2022

Updated: 12/2/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:C/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-31629

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 9/29/2022

Vulnerability Publication Date: 9/28/2022

Reference Information

CVE: CVE-2022-31628, CVE-2022-31629

IAVA: 2022-A-0397