Debian DLA-3128-1 : node-thenify - LTS security update

critical Nessus Plugin ID 165605

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 host has a package installed that is affected by a vulnerability as referenced in the dla-3128 advisory.

- This affects the package thenify before 3.3.1. The name argument provided to the package can be controlled by users without any sanitization, and this is provided to the eval function without any sanitization.
(CVE-2020-7677)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the node-thenify packages.

For Debian 10 buster, this problem has been fixed in version 3.3.0-1+deb10u1.

See Also

http://www.nessus.org/u?728f9798

https://www.debian.org/lts/security/2022/dla-3128

https://security-tracker.debian.org/tracker/CVE-2020-7677

https://packages.debian.org/source/buster/node-thenify

Plugin Details

Severity: Critical

ID: 165605

File Name: debian_DLA-3128.nasl

Version: 1.2

Type: local

Agent: unix

Published: 9/30/2022

Updated: 9/30/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-7677

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:node-thenify:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/1/2022

Vulnerability Publication Date: 7/25/2022

Reference Information

CVE: CVE-2020-7677