Ubuntu 20.04 LTS / 22.04 LTS : PCRE vulnerabilities (USN-5627-1)

critical Nessus Plugin ID 165325

Language:

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 20.04 LTS / 22.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5627-1 advisory.

- An out-of-bounds read vulnerability was discovered in the PCRE2 library in the compile_xclass_matchingpath() function of the pcre2_jit_compile.c file. This involves a unicode property matching issue in JIT-compiled regular expressions. The issue occurs because the character was not fully read in case-less matching within JIT. (CVE-2022-1586)

- An out-of-bounds read vulnerability was discovered in the PCRE2 library in the get_recurse_data_length() function of the pcre2_jit_compile.c file. This issue affects recursions in JIT-compiled regular expressions caused by duplicate data transfers. (CVE-2022-1587)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5627-1

Plugin Details

Severity: Critical

ID: 165325

File Name: ubuntu_USN-5627-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 9/22/2022

Updated: 9/22/2022

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-1587

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:canonical:ubuntu_linux:20.04:-:lts:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:22.04:-:lts:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libpcre2-16-0:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libpcre2-32-0:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libpcre2-8-0:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libpcre2-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libpcre2-posix2:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libpcre2-posix3:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:pcre2-utils:*:*:*:*:*:*:*

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 9/22/2022

Vulnerability Publication Date: 5/11/2022

Reference Information

CVE: CVE-2022-1587, CVE-2022-1586

USN: 5627-1