Artifex Ghostscript 9.55 DoS

medium Nessus Plugin ID 165303

Synopsis

The remote Windows host contains a library that is affected by a denial of service vulnerability.

Description

The version of Artifex Ghostscript installed on the remote Windows host is 9.55. It is, therefore, affected by a NULL pointer dereference vulnerabiulity leading to denial of service. The DoS occurs when Ghostscript tries to render a large number of bits in memory. When allocating a buffer device, it relies on an init_device_procs defined for the device that uses it as a prototype that depends upon the number of bits per pixel. For bpp > 64, mem_x_device is used and does not have an init_device_procs defined. This flaw allows an attacker to parse a large number of bits (more than 64 bits per pixel), which triggers a NULL pointer dereference flaw, causing an application to crash.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Artifex Ghostscript 9.56.0 or later.

See Also

https://bugs.ghostscript.com/show_bug.cgi?id=704945

Plugin Details

Severity: Medium

ID: 165303

File Name: ghostscript_9_55.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 9/22/2022

Updated: 9/28/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2085

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:artifex:ghostscript, cpe:/a:artifex:gpl_ghostscript

Required KB Items: installed_sw/Ghostscript

Exploit Ease: No known exploits are available

Patch Publication Date: 3/29/2022

Vulnerability Publication Date: 2/14/2022

Reference Information

CVE: CVE-2022-2085

IAVB: 2022-B-0034