Debian DLA-3115-1 : e17 - LTS security update

high Nessus Plugin ID 165256


The remote Debian host is missing a security-related update.


The remote Debian 10 host has packages installed that are affected by a vulnerability as referenced in the dla-3115 advisory.

- enlightenment_sys in Enlightenment before 0.25.4 allows local users to gain privileges because it is setuid root, and the system library function mishandles pathnames that begin with a /dev/.. substring.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the e17 packages.

For Debian 10 buster, this problem has been fixed in version 0.22.4-2+deb10u1.

See Also

Plugin Details

Severity: High

ID: 165256

File Name: debian_DLA-3115.nasl

Version: 1.7

Type: local

Agent: unix

Published: 9/20/2022

Updated: 3/21/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information


Risk Factor: Critical

Score: 9.6


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS Score Source: CVE-2022-37706


Risk Factor: High

Base Score: 7.8

Temporal Score: 7.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:e17, p-cpe:/a:debian:debian_linux:e17-data, p-cpe:/a:debian:debian_linux:enlightenment, p-cpe:/a:debian:debian_linux:enlightenment-data, p-cpe:/a:debian:debian_linux:enlightenment-dev, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/dpkg-l, Host/Debian/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/19/2022

Vulnerability Publication Date: 9/19/2022

Exploitable With

Metasploit (Ubuntu Enlightenment Mount Priv Esc)

Reference Information

CVE: CVE-2022-37706