Debian DLA-3100-1 : libgoogle-gson-java - LTS security update

high Nessus Plugin ID 164827

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 host has a package installed that is affected by a vulnerability as referenced in the dla-3100 advisory.

- The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks. (CVE-2022-25647)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the libgoogle-gson-java packages.

For Debian 10 buster, this problem has been fixed in version 2.8.5-3+deb10u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1010670

http://www.nessus.org/u?898134c5

https://www.debian.org/lts/security/2022/dla-3100

https://security-tracker.debian.org/tracker/CVE-2022-25647

https://packages.debian.org/source/buster/libgoogle-gson-java

Plugin Details

Severity: High

ID: 164827

File Name: debian_DLA-3100.nasl

Version: 1.2

Type: local

Agent: unix

Published: 9/7/2022

Updated: 9/7/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-25647

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libgoogle-gson-java, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 9/7/2022

Vulnerability Publication Date: 5/1/2022

Reference Information

CVE: CVE-2022-25647