Amazon Linux 2022 : (ALAS2022-2022-117)

high Nessus Plugin ID 164763

Synopsis

The remote Amazon Linux 2022 host is missing a security update.

Description

It is, therefore, affected by a vulnerability as referenced in the ALAS2022-2022-117 advisory.

- In zsh before 5.8.1, an attacker can achieve code execution if they control a command output inside the prompt, as demonstrated by a %F argument. This occurs because of recursive PROMPT_SUBST expansion.
(CVE-2021-45444)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'dnf update --releasever=2022.0.20220719 zsh' to update your system.

See Also

https://alas.aws.amazon.com/AL2022/ALAS-2022-117.html

https://alas.aws.amazon.com/cve/html/CVE-2021-45444.html

Plugin Details

Severity: High

ID: 164763

File Name: al2022_ALAS2022-2022-117.nasl

Version: 1.2

Type: local

Agent: unix

Published: 9/6/2022

Updated: 9/6/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 5.1

Temporal Score: 3.8

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-45444

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:zsh, p-cpe:/a:amazon:linux:zsh-debuginfo, p-cpe:/a:amazon:linux:zsh-debugsource, p-cpe:/a:amazon:linux:zsh-html, cpe:/o:amazon:linux:2022

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 7/20/2022

Vulnerability Publication Date: 2/12/2022

Reference Information

CVE: CVE-2021-45444