lighttpd < 1.3.8 Null Byte Request CGI Script Source Code Disclosure

Medium Nessus Plugin ID 16475


The remote web server is affected by an information disclosure vulnerability.


According to its banner, the version of lighttpd running on the remote host is prior to 1.3.8. It is, therefore, affected by an information disclosure vulnerability. An unauthenticated, remote attacker can exploit this vulnerability, by requesting a CGI script that is appended by a '%00', to read the source of the script.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to lighttpd version 1.3.8 or later

See Also

Plugin Details

Severity: Medium

ID: 16475

File Name: lighttpd_cgi.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2005/02/16

Modified: 2018/02/07

Dependencies: 106628

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Required KB Items: installed_sw/lighttpd

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2005/02/12

Reference Information

CVE: CVE-2005-0453

BID: 12567

OSVDB: 13844

GLSA: 200502-21