Mandrake Linux Security Advisory : emacs (MDKSA-2005:038)

High Nessus Plugin ID 16473


The remote Mandrake Linux host is missing one or more security updates.


Max Vozeler discovered several format string vulnerabilities in the movemail utility in Emacs. If a user connects to a malicious POP server, an attacker can execute arbitrary code as the user running emacs.

The updated packages have been patched to correct the problem.


Update the affected packages.

Plugin Details

Severity: High

ID: 16473

File Name: mandrake_MDKSA-2005-038.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/02/16

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:emacs, p-cpe:/a:mandriva:linux:emacs-X11, p-cpe:/a:mandriva:linux:emacs-doc, p-cpe:/a:mandriva:linux:emacs-el, p-cpe:/a:mandriva:linux:emacs-leim, p-cpe:/a:mandriva:linux:emacs-nox, p-cpe:/a:mandriva:linux:xemacs, p-cpe:/a:mandriva:linux:xemacs-devel, p-cpe:/a:mandriva:linux:xemacs-el, p-cpe:/a:mandriva:linux:xemacs-extras, p-cpe:/a:mandriva:linux:xemacs-packages, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/02/15

Reference Information

CVE: CVE-2005-0100

MDKSA: 2005:038