GLSA-200502-20 : Emacs, XEmacs: Format string vulnerabilities in movemail

High Nessus Plugin ID 16471


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200502-20 (Emacs, XEmacs: Format string vulnerabilities in movemail)

Max Vozeler discovered that the movemail utility contains several format string errors.
Impact :

An attacker could set up a malicious POP server and entice a user to connect to it using movemail, resulting in the execution of arbitrary code with the rights of the victim user.
Workaround :

There is no known workaround at this time.


All Emacs users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-editors/emacs-21.4' All XEmacs users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-editors/xemacs-21.4.15-r3'

See Also

Plugin Details

Severity: High

ID: 16471

File Name: gentoo_GLSA-200502-20.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/02/16

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:emacs, p-cpe:/a:gentoo:linux:xemacs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/02/15

Vulnerability Publication Date: 2005/02/07

Reference Information

CVE: CVE-2005-0100

OSVDB: 13588

GLSA: 200502-20