GitLab 14.8 < 14.10.5 / 15.0 < 15.0.4 / 15.1 < 15.1.1 Improper Authorization Vulnerability

medium Nessus Plugin ID 164478


A source control application running on the remote web server is affected by an improper authorization vulnerability.


According to its self-reported version, the instance of GitLab running on the remote web server is 14.8 prior to 14.10.5, 15.0 prior to 15.0.4, or 15.1 prior to 15.1.1. It is, therefore, affected by an improper authorization vulnerability that can allow project memebers with reporter role to manage issues in project's error tracking feature.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.10.5, 15.0.4, 15.1.1, or later.

See Also

Plugin Details

Severity: Medium

ID: 164478

File Name: gitlab_cve-2022-2244.nasl

Version: 1.4

Type: combined

Agent: unix

Family: CGI abuses

Published: 8/29/2022

Updated: 3/23/2023

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: Low

Score: 1.4


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2244


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 6/30/2022

Vulnerability Publication Date: 6/30/2022

Reference Information

CVE: CVE-2022-2244

IAVA: 2022-A-0263-S