GLSA-200501-40 : ngIRCd: Buffer overflow

High Nessus Plugin ID 16431


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200501-40 (ngIRCd: Buffer overflow)

Florian Westphal discovered a buffer overflow caused by an integer underflow in the Lists_MakeMask() function of lists.c.
Impact :

A remote attacker can exploit this buffer overflow to crash the ngIRCd daemon and possibly execute arbitrary code with the rights of the ngIRCd daemon process.
Workaround :

There is no known workaround at this time.


All ngIRCd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-irc/ngIRCd-0.8.2'

See Also

Plugin Details

Severity: High

ID: 16431

File Name: gentoo_GLSA-200501-40.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2005/02/14

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ngircd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/01/28

Vulnerability Publication Date: 2005/01/31

Reference Information

CVE: CVE-2005-0199

OSVDB: 13300

GLSA: 200501-40