GLSA-200501-32 : KPdf, KOffice: Stack overflow in included Xpdf code

High Nessus Plugin ID 16423


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200501-32 (KPdf, KOffice: Stack overflow in included Xpdf code)

KPdf and KOffice both include Xpdf code to handle PDF files. Xpdf is vulnerable to a new stack overflow, as described in GLSA 200501-28.
Impact :

An attacker could entice a user to open a specially crafted PDF file, potentially resulting in the execution of arbitrary code with the rights of the user running the affected application.
Workaround :

There is no known workaround at this time.


All KPdf users should upgrade to the latest version of kdegraphics:
# emerge --sync # emerge --ask --oneshot --verbose kde-base/kdegraphics All KOffice users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose app-office/koffice

See Also

Plugin Details

Severity: High

ID: 16423

File Name: gentoo_GLSA-200501-32.nasl

Version: $Revision: 1.19 $

Type: local

Published: 2005/02/14

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:kdegraphics, p-cpe:/a:gentoo:linux:koffice, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/01/23

Vulnerability Publication Date: 2005/01/18

Reference Information

CVE: CVE-2005-0064

OSVDB: 13050

GLSA: 200501-32