Splunk Enterprise Deployment Server < 9.0 Improper Authorization

high Nessus Plugin ID 164074

Synopsis

An application running on a remote web server host may be affected by an improper authorization vulnerability.

Description

The version of Splunk Enterprise installed on the remote host is prior to 9.0. It may, therefore, be affected by an improper authorization vulnerability if the Deployment Server component is in use where forwarder bundles can be downloaded without authentication.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade Splunk Enterprise to version 9.0, or later.

See Also

http://www.nessus.org/u?9e1a156a

Plugin Details

Severity: High

ID: 164074

File Name: splunk_900_cve-2022-32157.nasl

Version: 1.4

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 8/11/2022

Updated: 8/31/2022

Configuration: Enable paranoid mode

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-32157

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 6/14/2022

Vulnerability Publication Date: 6/14/2022

Reference Information

CVE: CVE-2022-32157

IAVA: 2022-A-0251-S