Tenable Nessus 8.x < 8.15.6 Multiple Vulnerabilities (TNS-2022-16)

high Nessus Plugin ID 164070

Synopsis

Tenable Nessus running on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version, the Tenable Nessus application running on the remote host is 8.x prior to 8.15.6. It is, therefore, affected by multiple vulnerabilities, including:

- An authenticated attacker could create an audit file that bypasses PowerShell cmdlet checks and executes commands with administrator privileges. (CVE-2022-32973)

- An authenticated attacker could read arbitrary files from the underlying operating system of the scanner using a custom crafted compliance audit file without providing any valid SSH credentials. (CVE-2022-32974)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Tenable Nessus version 8.15.6 or later.

See Also

https://www.tenable.com/security/tns-2022-16

Plugin Details

Severity: High

ID: 164070

File Name: nessus_TNS-2022-16.nasl

Version: 1.3

Type: remote

Family: Misc.

Published: 8/11/2022

Updated: 8/31/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-32973

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Ease: No known exploits are available

Patch Publication Date: 8/10/2022

Vulnerability Publication Date: 6/21/2022

Reference Information

CVE: CVE-2022-32973, CVE-2022-32974