GLSA-200501-11 : Dillo: Format string vulnerability

High Nessus Plugin ID 16402


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200501-11 (Dillo: Format string vulnerability)

Gentoo Linux developer Tavis Ormandy found a format string bug in Dillo's handling of messages in a_Interface_msg().
Impact :

An attacker could craft a malicious web page which, when accessed using Dillo, would trigger the format string vulnerability and potentially execute arbitrary code with the rights of the user running Dillo.
Workaround :

There is no known workaround at this time.


All Dillo users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/dillo-0.8.3-r4'

See Also

Plugin Details

Severity: High

ID: 16402

File Name: gentoo_GLSA-200501-11.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2005/02/14

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dillo, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/01/09

Vulnerability Publication Date: 2005/01/04

Reference Information

CVE: CVE-2005-0012

OSVDB: 12724, 12783

GLSA: 200501-11