GitLab 13.0 < 15.0.5 / 15.1 < 15.1.4 / 15.2 < 15.2.1 Improper Access

low Nessus Plugin ID 163888

Synopsis

A source control application running on the remote web server is affected by an improper access vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is 13.0 prior to 15.0.5, 15.1 prior to 15.1.4, or 15.2 prior to 15.2.1. It is, therefore, affected by an improper access vulnerability where a malicious Group Owner can retain a usable Group Access Token even after the Group is deleted, though the APIs usable by that token are limited.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 15.0.5, 15.1.4, 15.2.1, or later.

See Also

http://www.nessus.org/u?08b576f4

Plugin Details

Severity: Low

ID: 163888

File Name: gitlab_cve-2022-2307.nasl

Version: 1.4

Type: combined

Agent: unix

Family: CGI abuses

Published: 8/5/2022

Updated: 8/12/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 4

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2307

CVSS v3

Risk Factor: Low

Base Score: 3.8

Temporal Score: 3.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 7/28/2022

Vulnerability Publication Date: 7/28/2022

Reference Information

CVE: CVE-2022-2307

IAVA: 2022-A-0302