GitLab 15.0 < 15.0.5 / 15.1 < 15.1.4 / 15.2 < 15.2.1 Authentication Bypass

medium Nessus Plugin ID 163885

Synopsis

A source control application running on the remote web server is affected by a authentication bypass vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is prior to 15.0.5, 15.1 prior to 15.1.4, or 15.2 prior to 15.2.1. It is, therefore, affected by a authentication bypass vulnerability. It may be possible for group members to bypass 2FA enforcement enabled at the group level by using Resource Owner Password Credentials grant to obtain an access token without using 2FA.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 15.0.5, 15.1.4, 15.2.1 or later.

See Also

http://www.nessus.org/u?4d76f33e

Plugin Details

Severity: Medium

ID: 163885

File Name: gitlab_cve-2022-2303.nasl

Version: 1.3

Type: combined

Family: CGI abuses

Published: 8/5/2022

Updated: 8/8/2022

Risk Information

VPR

Risk Factor: Low

Score: 2.9

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2303

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 7/28/2022

Vulnerability Publication Date: 7/28/2022

Reference Information

CVE: CVE-2022-2303

IAVA: 2022-A-0302