GitLab 12.5 < 15.0.5 / 15.1 < 15.1.4 / 15.2 < 15.2.1 Improper Authentication

medium Nessus Plugin ID 163836

Synopsis

A source control application running on the remote web server is affected by an improper authentication vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is 12.5 prior to 15.0.5, 15.1 prior to 15.1.4, or 15.2 prior to 15.2.1. It is, therefore, affected by an improper authentication vulnerability where GitLab was not performing correct authentication on Grafana API under specific conditions allowing unauthenticated users to perform queries through a path traversal vulnerability.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 15.0.5, 15.1.4, 15.2.1, or later.

See Also

http://www.nessus.org/u?d88e3440

Plugin Details

Severity: Medium

ID: 163836

File Name: gitlab_cve-2022-2531.nasl

Version: 1.4

Type: combined

Agent: unix

Family: CGI abuses

Published: 8/4/2022

Updated: 8/8/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2531

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 7/28/2022

Vulnerability Publication Date: 7/28/2022

Reference Information

CVE: CVE-2022-2531

IAVA: 2022-A-0302