Fedora Core 3 : mod_python-3.1.3-5.2 (2005-140)

High Nessus Plugin ID 16374


The remote Fedora Core host is missing a security update.


Graham Dumpleton discovered a flaw affecting the publisher handler of mod_python, used to make objects inside modules callable via URL. A remote user could visit a carefully crafted URL that would gain access to objects that should not be visible, leading to an information leak.
The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2005-0088 to this issue.

This update includes a patch which fixes this issue.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected mod_python and / or mod_python-debuginfo packages.

See Also


Plugin Details

Severity: High

ID: 16374

File Name: fedora_2005-140.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2005/02/10

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:mod_python, p-cpe:/a:fedoraproject:fedora:mod_python-debuginfo, cpe:/o:fedoraproject:fedora_core:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2005/02/10

Reference Information

CVE: CVE-2005-0088

FEDORA: 2005-140