Tenable SecurityCenter < 5.22.0 Multiple Vulnerabilities (TNS-2022-15)

high Nessus Plugin ID 163634

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version, the Tenable SecurityCenter application installed on the remote host has a third-party software vulnerability in Moment.js, prior to version 2.29.4. It contains a denial of service vulnerability due to an inefficient parsing algorithm. An remote attacker can pass a specially crafted large message into the application and cause a noticeable slowdown.

Note that successful exploitation of the most serious issues can result in arbitrary code execution.

Solution

Apply the security patch referenced in the vendor advisory or upgrade to 5.22.0 or later.

See Also

https://www.tenable.com/security/tns-2022-15

https://www.tenable.com/security/tns-2022-18

http://www.nessus.org/u?7cba126f

Plugin Details

Severity: High

ID: 163634

File Name: securitycenter_5_22_0_tns_2022_07.nasl

Version: 1.3

Type: local

Agent: unix

Family: Misc.

Published: 7/29/2022

Updated: 9/23/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-31129

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Exploit Ease: No known exploits are available

Patch Publication Date: 7/28/2022

Vulnerability Publication Date: 7/28/2022

Reference Information

CVE: CVE-2022-31129