JQuery UI < 1.13.2 XSS

medium Nessus Plugin ID 163599


The remote web server is by a cross-site scripting vulnerabilities.


The version of JQuery UI library hosted on the remote web server is prior to 1.13.2. It is, therefore, affected by a cross-site scripting vulnerability in the JQuery UI that allows remote attackers to inject arbitrary web script or HTML via processing the value of a compromised checkboxradio widget.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to JQuery UI version 1.13.2 or later.

See Also


Plugin Details

Severity: Medium

ID: 163599

File Name: jquery-ui_1_13_2.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 7/29/2022

Updated: 8/1/2022

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3.8


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-31160


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery_ui

Exploit Ease: No known exploits are available

Patch Publication Date: 7/14/2022

Vulnerability Publication Date: 7/14/2022

Reference Information

CVE: CVE-2022-31160

IAVB: 2022-B-0022