Fortinet FortiAnalyzer Buffer Overflow (FG-IR-21-206)

high Nessus Plugin ID 163255

Synopsis

The remote host is affected by a buffer overflow vulnerability.

Description

The remote host is running a version of FortiAnalyzer that is 5.6.x through 5.6.11, 6.x through 6.0.11, 6.2.x through 6.2.9, 6.4.x through 6.4.7, or 7.x through 7.0.2. It is, therefore, affected by a buffer overflow vulnerability. An authenticated, remote attacker can exploit this issue, via the TFTP protocol with crafted CLI 'execute restore image' and 'execute certificate remote' operations, to execute arbitrary code or commands in the system.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update FortiAnalyzer to version 6.4.8, 7.0.3, or later.

See Also

https://www.fortiguard.com/psirt/FG-IR-21-206

Plugin Details

Severity: High

ID: 163255

File Name: fortianalyzer_FG-IR-21-206.nasl

Version: 1.3

Type: local

Family: CGI abuses

Published: 7/15/2022

Updated: 9/16/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-43072

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:fortinet:fortianalyzer

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Ease: No known exploits are available

Patch Publication Date: 7/5/2022

Vulnerability Publication Date: 7/5/2022

Reference Information

CVE: CVE-2021-43072