VMware vCenter Server 6.5 / 6.7 / 7.0 SSRF (VMSA-2022-0018)

high Nessus Plugin ID 163100

Synopsis

A virtualization management application installed on the remote host is affected by a server-side request forgery vulnerability.

Description

The version of VMware vCenter Server installed on the remote host is 6.5 prior to 6.5 U3t, 6.7 prior to 6.7 U3r, or 7.0 prior to 7.0 U3f. It is, therefore, affected by a server-side request forgery (SSRF) vulnerability. A remote attacker with network access to port 433 can exploit this send a URL request outside of vCenter Server or to an internal service.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number. Nessus has also not tested for the presence of a workaround.

Solution

Upgrade to VMware vCenter Server 6.5 U3t, 6.7 U3r, or 7.0 U3f or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2022-0018.html

Plugin Details

Severity: High

ID: 163100

File Name: vmware_vcenter_vmsa-2022-0018.nasl

Version: 1.8

Type: remote

Family: Misc.

Published: 7/14/2022

Updated: 8/12/2022

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-22982

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Ease: No known exploits are available

Patch Publication Date: 7/12/2022

Vulnerability Publication Date: 7/12/2022

Reference Information

CVE: CVE-2022-22982

IAVA: 2022-A-0278