GitLab 8.13 < 14.10.5 / 15.0 < 15.0.4 / 15.1 < 15.1.1 Improper Access

medium Nessus Plugin ID 163085

Synopsis

A source control application running on the remote web server is affected by an improper access vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is 8.13 prior to 14.10.5, 15.0 prior to 15.0.4, or 15.1 prior to 15.1.1. It is, therefore, affected by an improper access vulnerability whereby an unprivileged user can alter a labels description via the REST API.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.10.5, 15.0.4, 15.1.1, or later.

See Also

http://www.nessus.org/u?81c2f68e

Plugin Details

Severity: Medium

ID: 163085

File Name: gitlab_cve-2022-1999.nasl

Version: 1.4

Type: combined

Agent: unix

Family: CGI abuses

Published: 7/13/2022

Updated: 8/9/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-1999

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 6/30/2022

Vulnerability Publication Date: 6/30/2022

Reference Information

CVE: CVE-2022-1999

IAVA: 2022-A-0263-S