GitLab 14.5 < 14.10.5 / 15.0 < 15.0.4 / 15.1 < 15.1.1 XSS

medium Nessus Plugin ID 163074

Synopsis

A source control application running on the remote web server is affected by a cross-site scripting vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is 14.4 prior to 14.10.5, 15.0 prior to 15.0.4, or 15.1 prior to 15.1.1. It is, therefore, affected by a cross-site scripting vulnerability which allows an attacker to perform cross-site scripting when a victim clicks on a maliciously crafted ZenTao link.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 14.10.5, 15.0.4, 15.1.1, or later.

See Also

http://www.nessus.org/u?6d097c55

Plugin Details

Severity: Medium

ID: 163074

File Name: gitlab_cve-2022-2235.nasl

Version: 1.4

Type: combined

Agent: unix

Family: CGI abuses

Published: 7/13/2022

Updated: 8/9/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2235

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 6/30/2022

Vulnerability Publication Date: 6/30/2022

Reference Information

CVE: CVE-2022-2235

IAVA: 2022-A-0263-S