IBM MQ 8.0 <= 8.0.0.16 / 9.0 < 9.0.0.13 / 9.1 < 9.1.0.11 LTS / 9.1 < 9.2.5 CD / 9.2 LTS (6587837)

medium Nessus Plugin ID 162984

Synopsis

The remote web server is affected by a vulnerability.

Description

The version of IBM MQ Server running on the remote host is affected by a vulnerability as referenced in the 6587837 advisory.

- IBM MQ (IBM MQ for HPE NonStop 8.1.0) can inadvertently disclose sensitive information under certain circumstances to a local user from a stack trace. IBM X-Force ID: 218853. (CVE-2022-22325)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to IBM MQ 8.0.0.16 CU2, 9.0.0.13, 9.1.0.11 LTS, 9.2.5 CD or later. Alternatively, install APAR IT40099 where appropriate.

See Also

https://www.ibm.com/support/pages/node/6587837

Plugin Details

Severity: Medium

ID: 162984

File Name: ibm_mq_6587837.nasl

Version: 1.2

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 7/11/2022

Updated: 7/11/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Low

Base Score: 1.9

Temporal Score: 1.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-22325

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:ibm:websphere_mq:*:*:*:*:*:*:*:*, cpe:2.3:a:ibm:mq:*:*:*:*:*:*:*:*

Required KB Items: installed_sw/IBM WebSphere MQ

Exploit Ease: No known exploits are available

Patch Publication Date: 5/25/2022

Vulnerability Publication Date: 5/13/2022

Reference Information

CVE: CVE-2022-22325