Fedora Core 3 : squid-2.5.STABLE7-1.FC3.1 (2005-106)

High Nessus Plugin ID 16289


The remote Fedora Core host is missing a security update.


- Tue Feb 01 2005 Jay Fenlason <fenlason at redhat.com> 7:2.5.STABLE7-1.FC3.1

- Add more upstream patches, including fixes for bz#146783 Correct handling of oversized reply headers bz#146778 CVE-2005-0211 Buffer overflow in WCCP recvfrom() call

- Thu Jan 20 2005 Jay Fenlason <fenlason at redhat.com> 7:2.5.STABLE7-1.FC3

- Upgrade to 2.5.STABLE7 and 18 upstream patches.

- This includes fixes for CVE-2005-0094 CVE-2005-0095 CVE-2004-0096 and CVE-2004-0097. This closes bz#145543 and bz#141938

- This obsoletes Ulrich Drepper's -nonbl patch.

- Add a triggerin on samba-common to make /var/cache/samba/winbindd_privileged accessible so that ntlm_auth will work. This fixes bz#103726

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected squid and / or squid-debuginfo packages.

See Also


Plugin Details

Severity: High

ID: 16289

File Name: fedora_2005-106.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2005/02/02

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:squid, p-cpe:/a:fedoraproject:fedora:squid-debuginfo, cpe:/o:fedoraproject:fedora_core:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2005/02/01

Reference Information

FEDORA: 2005-106