GitLab 12.0.0 < 14.9.5 / 14.10.0 < 14.10.4 / 15.0.0 < 15.0.1 (CVE-2022-1935)

medium Nessus Plugin ID 162569


The version of GitLab installed on the remote host is affected by a vulnerability.


The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- Incorrect authorization in GitLab EE affecting all versions from 12.0 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1 allowed an attacker already in possession of a valid Project Trigger Token to misuse it from any location even when IP address restrictions were configured (CVE-2022-1935)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 14.9.5, 14.10.4, 15.0.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 162569

File Name: gitlab_CVE-2022-1935.nasl

Version: 1.4

Type: combined

Agent: unix

Family: CGI abuses

Published: 6/28/2022

Updated: 5/17/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2022-1935


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 6/1/2022

Vulnerability Publication Date: 6/1/2022

Reference Information

CVE: CVE-2022-1935