Debian DLA-3053-1 : vim - LTS security update

high Nessus Plugin ID 162406

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-3053 advisory.

- vim is vulnerable to Heap-based Buffer Overflow (CVE-2021-3903)

- Heap-based Buffer Overflow GitHub repository vim/vim prior to 8.2. (CVE-2022-0417)

- Heap-based Buffer Overflow occurs in vim in GitHub repository vim/vim prior to 8.2.4563. (CVE-2022-0943)

- Buffer Over-read in function grab_file_name in GitHub repository vim/vim prior to 8.2.4956. This vulnerability is capable of crashing the software, memory modification, and possible remote execution.
(CVE-2022-1720)

- Out-of-bounds Read in GitHub repository vim/vim prior to 8.2. (CVE-2022-1851, CVE-2022-2126)

- Use After Free in GitHub repository vim/vim prior to 8.2. (CVE-2022-1898, CVE-2022-1968)

- Buffer Over-read in GitHub repository vim/vim prior to 8.2. (CVE-2022-2124)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vim packages.

For Debian 9 stretch, these problems have been fixed in version 2

See Also

https://security-tracker.debian.org/tracker/source-package/vim

https://www.debian.org/lts/security/2022/dla-3053

https://security-tracker.debian.org/tracker/CVE-2021-3903

https://security-tracker.debian.org/tracker/CVE-2022-0417

https://security-tracker.debian.org/tracker/CVE-2022-0943

https://security-tracker.debian.org/tracker/CVE-2022-1720

https://security-tracker.debian.org/tracker/CVE-2022-1851

https://security-tracker.debian.org/tracker/CVE-2022-1898

https://security-tracker.debian.org/tracker/CVE-2022-1968

https://security-tracker.debian.org/tracker/CVE-2022-2124

https://security-tracker.debian.org/tracker/CVE-2022-2126

https://packages.debian.org/source/stretch/vim

Plugin Details

Severity: High

ID: 162406

File Name: debian_DLA-3053.nasl

Version: 1.2

Type: local

Agent: unix

Published: 6/20/2022

Updated: 6/20/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-1968

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:vim, p-cpe:/a:debian:debian_linux:vim-athena, p-cpe:/a:debian:debian_linux:vim-common, p-cpe:/a:debian:debian_linux:vim-doc, p-cpe:/a:debian:debian_linux:vim-gnome, p-cpe:/a:debian:debian_linux:vim-gtk, p-cpe:/a:debian:debian_linux:vim-gtk3, p-cpe:/a:debian:debian_linux:vim-gui-common, p-cpe:/a:debian:debian_linux:vim-nox, p-cpe:/a:debian:debian_linux:vim-runtime, p-cpe:/a:debian:debian_linux:vim-tiny, p-cpe:/a:debian:debian_linux:xxd, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 6/20/2022

Vulnerability Publication Date: 10/27/2021

Reference Information

CVE: CVE-2021-3903, CVE-2022-0417, CVE-2022-0943, CVE-2022-1720, CVE-2022-1851, CVE-2022-1898, CVE-2022-1968, CVE-2022-2124, CVE-2022-2126