Debian DLA-3052-1 : cyrus-imapd - LTS security update

critical Nessus Plugin ID 162402

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-3052 advisory.

- Cyrus IMAP 2.5.x before 2.5.14 and 3.x before 3.0.12 allows privilege escalation because an HTTP request may be interpreted in the authentication context of an unrelated previous request that arrived over the same connection. (CVE-2019-18928)

- Cyrus IMAP before 3.4.2 allows remote attackers to cause a denial of service (multiple-minute daemon hang) via input that is mishandled during hash-table interaction. Because there are many insertions into a single bucket, strcmp becomes slow. This is fixed in 3.4.2, 3.2.8, and 3.0.16. (CVE-2021-33582)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the cyrus-imapd packages.

For Debian 9 stretch, these problems have been fixed in version 2.5.10-3+deb9u3.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=993433

https://security-tracker.debian.org/tracker/source-package/cyrus-imapd

https://www.debian.org/lts/security/2022/dla-3052

https://security-tracker.debian.org/tracker/CVE-2019-18928

https://security-tracker.debian.org/tracker/CVE-2021-33582

https://packages.debian.org/source/stretch/cyrus-imapd

Plugin Details

Severity: Critical

ID: 162402

File Name: debian_DLA-3052.nasl

Version: 1.2

Type: local

Agent: unix

Published: 6/20/2022

Updated: 6/20/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2019-18928

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:cyrus-admin, p-cpe:/a:debian:debian_linux:cyrus-caldav, p-cpe:/a:debian:debian_linux:cyrus-clients, p-cpe:/a:debian:debian_linux:cyrus-common, p-cpe:/a:debian:debian_linux:cyrus-dev, p-cpe:/a:debian:debian_linux:cyrus-doc, p-cpe:/a:debian:debian_linux:cyrus-imapd, p-cpe:/a:debian:debian_linux:cyrus-murder, p-cpe:/a:debian:debian_linux:cyrus-nntpd, p-cpe:/a:debian:debian_linux:cyrus-pop3d, p-cpe:/a:debian:debian_linux:cyrus-replication, p-cpe:/a:debian:debian_linux:libcyrus-imap-perl, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 6/20/2022

Vulnerability Publication Date: 11/15/2019

Reference Information

CVE: CVE-2019-18928, CVE-2021-33582