VERITAS Backup Exec Agent Browser Registration Request Remote Overflow

Critical Nessus Plugin ID 16232


Arbitrary code can be executed on the remote host.


The remote host is running a version of VERITAS Backup Exec Agent Browser which is vulnerable to a remote buffer overflow. An attacker may exploit this flaw to execute arbitrary code on the remote host or to disable this service remotely.

To exploit this flaw, an attacker would need to send a specially crafted packet to the remote service.


Plugin Details

Severity: Critical

ID: 16232

File Name: veritas_backup_exec_overflow2.nasl

Version: $Revision: 1.20 $

Type: remote

Published: 2005/01/24

Modified: 2015/01/15

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:symantec:veritas_backup_exec

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/02/08

Vulnerability Publication Date: 2004/12/16

Exploitable With

Core Impact

Metasploit (Veritas Backup Exec Name Service Overflow)

Reference Information

CVE: CVE-2004-1172

BID: 11974

OSVDB: 12418