Adobe Animate < 21.0.6 / 22.x < 22.0.6 Code Execution (APSB22-24)

high Nessus Plugin ID 162319

Synopsis

Adobe Animate installed on remote host is affected by an arbitrary code execution vulnerability.

Description

The version of Adobe Animate installed on the remote host is affected by an arbitrary code execution vulnerability due to an out-of-bounds write. An unauthenticated, local attacker can exploit this to execute code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Animate version 21.0.11, 22.0.6, or later.

See Also

https://helpx.adobe.com/security/products/animate/apsb22-24.html

Plugin Details

Severity: High

ID: 162319

File Name: adobe_animate_apsb22-24.nasl

Version: 1.5

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 6/16/2022

Updated: 9/19/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-30664

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:animate

Required KB Items: installed_sw/Adobe Animate

Exploit Ease: No known exploits are available

Patch Publication Date: 6/14/2022

Vulnerability Publication Date: 6/14/2022

Reference Information

CVE: CVE-2022-30664

IAVA: 2022-A-0236-S