Mandrake Linux Security Advisory : playmidi (MDKSA-2005:010)

High Nessus Plugin ID 16219


The remote Mandrake Linux host is missing one or more security updates.


Erik Sjolund discovered a buffer overflow in playmidi that could be exploited by a local attacker if installed setuid root. Note that by default Mandrakelinux does not ship playmidi installed setuid root.


Update the affected playmidi and / or playmidi-X11 packages.

Plugin Details

Severity: High

ID: 16219

File Name: mandrake_MDKSA-2005-010.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/01/19

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:playmidi, p-cpe:/a:mandriva:linux:playmidi-X11, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/01/19

Reference Information

CVE: CVE-2005-0020

MDKSA: 2005:010