Adobe InCopy < 16.4.2 / 17.0 < 17.3 Multiple Vulnerabilities Arbitrary code execution (APSB22-29)

high Nessus Plugin ID 162182

Synopsis

The Adobe InCopy instance installed on the remote host is affected by multiple vulnerabilities.

Description

The version of Adobe InCopy installed on the remote host is prior to 16.4.2, 17.3. It is, therefore, affected by multiple vulnerabilities as referenced in the APSB22-29 advisory.

- Heap-based Buffer Overflow (CWE-122) potentially leading to Arbitrary code execution (CVE-2022-30650, CVE-2022-30654)

- Out-of-bounds Read (CWE-125) potentially leading to Arbitrary code execution (CVE-2022-30651)

- Out-of-bounds Write (CWE-787) potentially leading to Arbitrary code execution (CVE-2022-30652, CVE-2022-30653, CVE-2022-30656)

- Use After Free (CWE-416) potentially leading to Arbitrary code execution (CVE-2022-30655, CVE-2022-30657)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe InCopy version 16.4.2, 17.3 or later.

See Also

https://helpx.adobe.com/security/products/incopy/apsb22-29.html

Plugin Details

Severity: High

ID: 162182

File Name: adobe_incopy_apsb22-29.nasl

Version: 1.5

Type: local

Family: Misc.

Published: 6/14/2022

Updated: 9/19/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-30657

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:incopy

Required KB Items: installed_sw/Adobe InCopy

Exploit Ease: No known exploits are available

Patch Publication Date: 6/14/2022

Vulnerability Publication Date: 6/14/2022

Reference Information

CVE: CVE-2022-30650, CVE-2022-30651, CVE-2022-30652, CVE-2022-30653, CVE-2022-30654, CVE-2022-30655, CVE-2022-30656, CVE-2022-30657

IAVA: 2022-A-0246-S

CWE: 122, 125, 416, 787