Mandrake Linux Security Advisory : mpg123 (MDKSA-2005:009)

High Nessus Plugin ID 16218


The remote Mandrake Linux host is missing a security update.


A vulnerability in mpg123's ability to parse frame headers in input streams could allow a malicious file to exploit a buffer overflow and execute arbitrary code with the permissions of the user running mpg123.

The updated packages have been patched to prevent these problems.


Update the affected mpg123 package.

Plugin Details

Severity: High

ID: 16218

File Name: mandrake_MDKSA-2005-009.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2005/01/19

Modified: 2014/04/15

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:mpg123, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/01/19

Reference Information

CVE: CVE-2004-0991

MDKSA: 2005:009