Amazon Linux AMI : expat (ALAS-2022-1588)

high Nessus Plugin ID 162001

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

The version of expat installed on the remote host is prior to 2.1.0-12.28. It is, therefore, affected by a vulnerability as referenced in the ALAS-2022-1588 advisory.

- In Expat (aka libexpat) before 2.4.3, a left shift by 29 (or more) places in the storeAtts function in xmlparse.c can lead to realloc misbehavior (e.g., allocating too few bytes, or only freeing memory).
(CVE-2021-45960)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update expat' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2022-1588.html

https://alas.aws.amazon.com/cve/html/CVE-2021-45960.html

Plugin Details

Severity: High

ID: 162001

File Name: ala_ALAS-2022-1588.nasl

Version: 1.3

Type: local

Agent: unix

Published: 6/10/2022

Updated: 10/25/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2021-45960

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:expat-devel, p-cpe:/a:amazon:linux:expat, p-cpe:/a:amazon:linux:expat-debuginfo, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/31/2022

Vulnerability Publication Date: 1/1/2022

Reference Information

CVE: CVE-2021-45960