SonicWall Secure Mobile Access (SMA) 12.4.x < 12.4.1-02994 Multiple Vulnerabilities (SNWLID-2022-0009)

critical Nessus Plugin ID 161951

Synopsis

The remote device is affected by multiple vulnerabilities.

Description

The remote host is a SonicWall Secure Mobile Access (SMA) device that may be affected by multiple vulnerabilities:

- SonicWall SMA1000 series firmware 12.4.0, 12.4.1-02965 and earlier versions uses a shared and hard-coded encryption key to store data. (CVE-2022-1701)

- SonicWall SMA1000 series firmware 12.4.0, 12.4.1-02965 and earlier versions accept a user-controlled input that specifies a link to an external site and uses that link in a redirect which leads to Open redirection vulnerability. (CVE-2022-1702)

- SonicWall SMA1000 series firmware 12.4.0, 12.4.1-02965 and earlier versions incorrectly restricts access to a resource using HTTP connections from an unauthorized actor leading to Improper Access Control vulnerability. (CVE-2022-22282)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to a SonicWall SMA version that is 12.4.1-02994 or later.

See Also

https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2022-0009

Plugin Details

Severity: Critical

ID: 161951

File Name: sonicwall_sma_SNWLID-2022-0009.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 6/8/2022

Updated: 6/10/2022

Configuration: Enable paranoid mode, Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-22282

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/o:sonicwall:firmware

Required KB Items: installed_sw/SonicWall Secure Mobile Access, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 5/12/2022

Vulnerability Publication Date: 5/12/2022

Reference Information

CVE: CVE-2022-1701, CVE-2022-1702, CVE-2022-22282

IAVA: 2022-A-0229