Dell EMC iDRAC8 < 2.80.80.80 / Dell EMC iDRAC9 < 4.40.40.00 (DSA-2021-177)

high Nessus Plugin ID 161798

Synopsis

Dell EMC iDRAC8/Dell EMC iDRAC9 installed on the remote host is affected by a vulnerability.

Description

The version of Dell EMC iDRAC8 or Dell EMC iDRAC9 installed on the remote host is affected by a vulnerability as referenced in the DSA-2021-177 advisory:

- Dell iDRAC 9 prior to version 4.40.40.00 and iDRAC 8 prior to version 2.80.80.80 contain a Stack Buffer Overflow in Racadm. An authenticated remote attacker may potentially exploit this vulnerability to control process execution and gain access to the underlying operating system. (CVE-2021-36301)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Dell EMC iDRAC8 version 2.80.80.80 or later. Upgrade to Dell EMC iDRAC9 version 4.40.40.00 or later.

See Also

http://www.nessus.org/u?13d440ac

Plugin Details

Severity: High

ID: 161798

File Name: drac_dsa-2021-177_2_80_80_80_4_40_40_00.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 6/3/2022

Updated: 6/6/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-36301

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:dell:emc_idrac8, cpe:/h:dell:emc_idrac9, x-cpe:/h:dell:emc_idrac8, x-cpe:/a:dell:emc_idrac9

Required KB Items: installed_sw/iDRAC

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2021

Vulnerability Publication Date: 9/9/2021

Reference Information

CVE: CVE-2021-36301

IAVA: 2022-A-0225