Dell EMC iDRAC9 < 5.00.10.00 (DSA-2021-177)

high Nessus Plugin ID 161797

Synopsis

Dell EMC iDRAC9 installed on the remote host is affected by a vulnerability.

Description

The version of Dell EMC iDRAC9 installed on the remote host is prior to 5.00.10.00. It is, therefore, affected by a vulnerability as referenced in the DSA-2021-177 advisory.

- There's a flaw in the zeromq server in versions before 4.3.3 in src/decoder_allocators.hpp. The decoder static allocator could have its sized changed, but the buffer would remain the same as it is a static buffer. A remote, unauthenticated attacker who sends a crafted request to the zeromq server could trigger a buffer overflow WRITE of arbitrary data if CURVE/ZAP authentication is not enabled. The greatest impact of this flaw is to application availability, data integrity, and confidentiality. (CVE-2021-20235)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

See vendor advisory

See Also

http://www.nessus.org/u?13d440ac

Plugin Details

Severity: High

ID: 161797

File Name: drac_dsa-2021-177_5_00_10_00.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 6/3/2022

Updated: 6/6/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-20235

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/h:dell:emc_idrac9, x-cpe:/a:dell:emc_idrac9

Required KB Items: installed_sw/iDRAC, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2021

Vulnerability Publication Date: 9/9/2021

Reference Information

CVE: CVE-2021-20235

IAVA: 2022-A-0225