SAP NetWeaver AS ABAP and Code Injection (3123196)

medium Nessus Plugin ID 161664

Synopsis

The remote SAP NetWeaver server is affected by a code injection vulnerability.

Description

A code injection vulnerability exists in SAP NetWeaver Application Server ABAP. This could allow an attacker with high privileges and has direct access to SAP System, to inject code when executing with a certain transaction class builder. This could allow execution of arbitrary commands on the operating system, that could highly impact the Confidentiality, Integrity and Availability of the system.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Apply the appropriate patch according to the vendor advisory.

See Also

https://launchpad.support.sap.com/#/notes/3123196

http://www.nessus.org/u?e388843b

Plugin Details

Severity: Medium

ID: 161664

File Name: sap_netweaver_as_3123196.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 5/30/2022

Updated: 5/31/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-44235

CVSS v3

Risk Factor: Medium

Base Score: 6.7

Temporal Score: 5.8

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:sap:netweaver_application_server

Required KB Items: installed_sw/SAP Netweaver Application Server (AS), Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 12/14/2021

Vulnerability Publication Date: 12/14/2021

Reference Information

CVE: CVE-2021-44235

IAVA: 2021-A-0599