Fedora Core 3 : kernel-2.6.10-1.741_FC3 (2005-025)

Critical Nessus Plugin ID 16166


The remote Fedora Core host is missing a security update.


- CVE-2005-0001

Paul Starzetz from isec.pl found an exploitable hole in the x86 SMP page fault handler which could lead to privilege escalation.
http://www.isec.pl/vulnerabilities/isec-0022-pagefault.t xt

This update additionally fixes a random memory corruption issue present in the previous update, and in addition updates to the latest
-ac collection of patches. A full changelog of the update vs the previous -ac8 based release is available at http://lkml.org/lkml/2005/1/13/219

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

See Also




Plugin Details

Severity: Critical

ID: 16166

File Name: fedora_2005-025.nasl

Version: $Revision: 1.14 $

Type: local

Agent: unix

Published: 2005/01/14

Modified: 2016/01/14

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:kernel, p-cpe:/a:fedoraproject:fedora:kernel-debuginfo, p-cpe:/a:fedoraproject:fedora:kernel-doc, p-cpe:/a:fedoraproject:fedora:kernel-smp, cpe:/o:fedoraproject:fedora_core:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/01/13

Reference Information

CVE: CVE-2005-0001, CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, CVE-2005-3627

FEDORA: 2005-025