Debian DLA-3028-1 : atftp - LTS security update

medium Nessus Plugin ID 161624

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has packages installed that are affected by a vulnerability as referenced in the dla-3028 advisory.

- options.c in atftp before 0.7.5 reads past the end of an array, and consequently discloses server-side /etc/group data to a remote client. (CVE-2021-46671)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the atftp packages.

For Debian 9 stretch, this problem has been fixed in version 0.7.git20120829-3.1~deb9u3.

See Also

https://security-tracker.debian.org/tracker/source-package/atftp

https://www.debian.org/lts/security/2022/dla-3028

https://security-tracker.debian.org/tracker/CVE-2021-46671

https://packages.debian.org/source/stretch/atftp

Plugin Details

Severity: Medium

ID: 161624

File Name: debian_DLA-3028.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/27/2022

Updated: 5/27/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-46671

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:atftp, p-cpe:/a:debian:debian_linux:atftpd, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/27/2022

Vulnerability Publication Date: 2/4/2022

Reference Information

CVE: CVE-2021-46671