Debian DLA-3025-1 : irssi - LTS security update

high Nessus Plugin ID 161618

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has packages installed that are affected by a vulnerability as referenced in the dla-3025 advisory.

- Irssi before 1.0.8, 1.1.x before 1.1.3, and 1.2.x before 1.2.1, when SASL is enabled, has a use after free when sending SASL login to the server. (CVE-2019-13045)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the irssi packages.

For Debian 9 Stretch, these problems have been fixed in version 1.0.7-1~deb9u2.

See Also

https://www.debian.org/lts/security/2022/dla-3025

https://security-tracker.debian.org/tracker/CVE-2019-13045

https://packages.debian.org/source/stretch/irssi

Plugin Details

Severity: High

ID: 161618

File Name: debian_DLA-3025.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/27/2022

Updated: 5/27/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2019-13045

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:irssi, p-cpe:/a:debian:debian_linux:irssi-dev, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/26/2022

Vulnerability Publication Date: 6/29/2019

Reference Information

CVE: CVE-2019-13045