Apache 2.4.x < 2.4.52 mod_lua Buffer Overflow

critical Nessus Plugin ID 161454


The remote web server is affected by a buffer overflow vulnerability.


The version of Apache httpd installed on the remote host is prior to 2.4.52. It is, therefore, affected by a flaw related to mod_lua when handling multipart content. A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerability though it might be possible to craft one.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache version 2.4.52 or later.

Plugin Details

Severity: Critical

ID: 161454

File Name: apache_2_4_52_CVE-2021-44790.nasl

Version: 1.4

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 5/24/2022

Updated: 5/26/2022

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information


Risk Factor: High

Score: 8.4


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-44790


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Ease: No known exploits are available

Patch Publication Date: 12/20/2021

Vulnerability Publication Date: 11/18/2021

Reference Information

CVE: CVE-2021-44790

IAVA: 2021-A-0604-S