Ubuntu 16.04 ESM : libXrender vulnerabilities (USN-5436-1)

critical Nessus Plugin ID 161450


The remote Ubuntu host is missing one or more security updates.


The remote Ubuntu 16.04 ESM host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5436-1 advisory.

- Multiple buffer overflows in the (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXrender before 0.9.10 allow remote X servers to trigger out-of-bounds write operations via vectors involving length fields. (CVE-2016-7949)

- The XRenderQueryFilters function in X.org libXrender before 0.9.10 allows remote X servers to trigger out- of-bounds write operations via vectors involving filter name lengths. (CVE-2016-7950)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Update the affected libxrender-dev and / or libxrender1 packages.

See Also


Plugin Details

Severity: Critical

ID: 161450

File Name: ubuntu_USN-5436-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/24/2022

Updated: 5/24/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2016-7950


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:esm, p-cpe:/a:canonical:ubuntu_linux:libxrender-dev, p-cpe:/a:canonical:ubuntu_linux:libxrender1

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/23/2022

Vulnerability Publication Date: 10/4/2016

Reference Information

CVE: CVE-2016-7949, CVE-2016-7950

USN: 5436-1